CI20 won't connect to bluetooth speaker

Home Forums Creator Platforms CI20 won't connect to bluetooth speaker

This topic contains 3 replies, has 2 voices, and was last updated by  john lam 1 year, 1 month ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #63698

    john lam
    Participant

    I am having trouble trying to pair my bluetooth speaker to the ci20. It can detect the bluetooth speaker, and will connect first time I pair it but drops off after 2 seconds. I then try to reconnect to it but get a

    Connection Failed: Nosuch file or directory

    and this happens every time I try to reconnect.

    #63701

    john lam
    Participant

    So I try to connect via command line to see what sort of error message I get and here is the output when using gatttool

    /etc/pulse$ gatttool -b BC:66:41:E0:24:A8 -i hci0 -I
    [BC:66:41:E0:24:A8][LE]> connect
    Attempting to connect to BC:66:41:E0:24:A8
    Error: connect error: Transport endpoint is not connected (134)
    [BC:66:41:E0:24:A8][LE]>
    
    #63700

    ZubairLK
    Participant

    Hi John,

    Could you perhaps share which Debian version you are running and which image is flashed on the Ci20?

    The Bluetooth hardware is a bit of a black box basically. The kernel loads the firmware for the chip. And then the interface to the bluetooth chip from the JZ4780 and kernel perspective is a simple UART tx/rx wire. I’m not aware of any kernel configuration options required for Bluetooth audio.

    The rest of the Bluetooth stack is in userspace as far as I know. You could check your BlueZ version perhaps. If you are using pulse-audio, perhaps you would need to install pulseaudio-module-bluetooth ?

    Regards,
    ZubairLK

    #63699

    john lam
    Participant

    Hi Zubair,

    I am currently running Debian GNU/Linux 8.

    I also have these pulseaudio packages installed:
    pulseaudio/stable,now 5.0-13 mipsel [installed]
    pulseaudio-module-bluetooth/stable,now 5.0-13 mipsel [installed]
    pulseaudio-module-x11/stable,now 5.0-13 mipsel [installed,automatic]
    pulseaudio-utils/stable,now 5.0-13 mipsel [installed,automatic]

    and some bluez ones installed:
    blueman/stable,stable,now 1.99~alpha1-1+deb8u1 mipsel [installed]
    bluez/stable,now 5.23-2+b1 mipsel [installed]
    bluez-obexd/stable,now 5.23-2+b1 mipsel [installed,automatic]

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently locked.