Codescape debugger unable to connect to the Minimorph board

Home Forums MIPS Insider Meta Insider Codescape debugger unable to connect to the Minimorph board

This topic contains 20 replies, has 2 voices, and was last updated by  Sean 5 years, 1 month ago.

Viewing 6 posts - 16 through 21 (of 21 total)
  • Author
    Posts
  • #64806

    Sean
    Moderator

    We have received the report, unfortunately no more helpful information is in it. We are looking to see if we can create a connection diagnostics program to get more targeted information. This is not an issue we have seen anywhere else!

    One suggestion for now is that you could try connecting the Minimorph to your wifi (if your network administrators would allow) and try connecting through that? To do this, either

    • Plug in a HDMI monitor and follow the WiFi config setup on screen using the 3 push buttons.
    • If you do not have a monitor use the following commands on the prompt, replacing the variables with the data for your network:
      nvs_write view.wifi_setup.iface wlan0
      nvs_write view.wifi_setup.ssid $WIFI-NAME
      nvs_write view.wifi_setup.psk $WIFI-PASSWORD
    • Reboot the Minimorph and it will connect on startup
    #64805

    Jialun_Liu
    Participant

    We have received the report, unfortunately no more helpful information is in it. We are looking to see if we can create a connection diagnostics program to get more targeted information. This is not an issue we have seen anywhere else!

    One suggestion for now is that you could try connecting the Minimorph to your wifi (if your network administrators would allow) and try connecting through that? To do this, either

    • Plug in a HDMI monitor and follow the WiFi config setup on screen using the 3 push buttons.
    • If you do not have a monitor use the following commands on the prompt, replacing the variables with the data for your network:
      nvs_write view.wifi_setup.iface wlan0
      nvs_write view.wifi_setup.ssid $WIFI-NAME
      nvs_write view.wifi_setup.psk $WIFI-PASSWORD
    • Reboot the Minimorph and it will connect on startup

    I have tried the command and reconnected the Minimorph, but when I tried to connect to the board with my IP address, I still failed…. Is there any other way I could let csdebugger connect to the target?

    Just to be sure, the ‘Minimorph Development Kit v1.9 ‘ is the only thing I need to download and install, right?

    Thank you very much for your help.

    #64804

    Sean
    Moderator

    Just to be sure, did you try to connect to the IP address of the wlan0 adaptor rather than the usb0 adaptor?

    Hopefully I’ll be able to get a connection diagnostics program over to you shortly.

    Minimorph Development Kit v1.9 and Codescape Debugger Mini version 7.1, yes.

    #64803

    Sean
    Moderator

    I have sent you the script with instructions by email.

    #64802

    Sean
    Moderator

    Did you get the Minimorph up and running with Codescape?

    #64801

    Jialun_Liu
    Participant

    Did you get the Minimorph up and running with Codescape?

    I am using static IP address to save time, thank you for your help.

Viewing 6 posts - 16 through 21 (of 21 total)

Forums are currently locked.