Error message when running loadMIPSfpga.bat

Home Forums MIPS Academic Forum / University MIPSfpga discussion Error message when running loadMIPSfpga.bat

This topic contains 1 reply, has 1 voice, and was last updated by  Jay Ng 4 months, 1 week ago.

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #115986

    Jay Ng
    Participant

    I am trying to use BUS BLASTER PROBE with BASYS-3 board.

    I was looking at Sarah Harris’s video Module 14.

    When I run the loadMIPSfpga.bat file and point to ReadSwitches folder as per her video, I see 2 windows pop-up with the following message.

    1) Window 1 is OpenOCD and it says “The system cannot find the path specified”

    2) Window 2 is GDB and it says ”

    ——————————————————————–

    Reading symbols from program.elf…done.
    c:\Office\MIPS_FPGA\MIPSfpga_GSG_v2.0.0\MIPSfpga_GSG\Scripts\Nexys4_DDR\..\startup.txt:1: Error in

    sourced command file:
    localhost:3333: The system tried to join a drive to a directory on a joined drive.
    (gdb)
    ——————————————————————-

    I am powering BASYS-3 board using USB port on my laptop.
    I am powering BUS blaster using USB port on the docking station that is connected to my laptop.
    Can you please help me with this issue?

    #115987

    Jay Ng
    Participant

    Here is the issue and the fix.
    ——————————————-
    1) Web installer only installs OpenOCD 0.10. It does not install Codescape (since access is forbidden).
    2) No-Web installer installs OpenOCD 0.10.3 and Codescape.
    3) What is needed is OpenOCD 0.10 and Codescape.
    4) I had OpenOCD 0.10.3 and Codescape and it does not recognize the PATH.
    5) I ran both installers and installed both version of OpenOCD and it works.
    6) You also need to run Zadig and install the drivers for BusBlaster Interface 0 and 1.
    ——————————————

Viewing 2 posts - 1 through 2 (of 2 total)

Forums are currently locked.