error while building meta 3.6

Home Forums MIPS Insider Meta Insider error while building meta 3.6

This topic contains 12 replies, has 2 voices, and was last updated by  Sean 4 years, 10 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #64775

    surender
    Member

    while make on ubuntu 12.04

    /home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4-initial/./gcc/xgcc -B/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4-initial/./gcc/ -B/home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/metag-unknown-linux-uclibc/bin/ -B/home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/metag-unknown-linux-uclibc/lib/ -isystem /home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/metag-unknown-linux-uclibc/include -isystem /home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/metag-unknown-linux-uclibc/sys-include -O2 -g -Os -DIN_GCC -DCROSS_COMPILE -W -Wall -Wwrite-strings -Wstrict-prototypes -Wmissing-prototypes -Wold-style-definition -isystem ./include -I. -I. -I/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc -I/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc/. -I/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc/../include -I/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc/../libcpp/include -I/home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/include -I/home/user/Minimorph_1_0/GPL/buildroot/output/host/usr/include -I/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc/../libdecnumber -I../libdecnumber -g0 -finhibit-size-directive -fno-inline-functions -fno-exceptions -fno-zero-initialized-in-bss -fno-toplevel-reorder -Dinhibit_libc -fPIC
    -c /home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4/gcc/crtstuff.c -DCRT_END -DCRTSTUFFS_O
    -o crtendS.o
    Assembler messages:
    Assembler messages:
    Error: Assembler messages:
    Error: Assembler messages:
    Error: Error: unrecognized option -minimunrecognized option -minim

    unrecognized option -minim
    unrecognized option -minim
    make[2]: *** [crtbeginS.o] Error 1
    make[2]: *** Waiting for unfinished jobs….
    make[2]: *** [crtend.o] Error 1
    make[2]: *** [crtbegin.o] Error 1
    make[2]: *** [crtendS.o] Error 1
    make[2]: Leaving directory `/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4-initial/gcc’
    make[1]: *** [all-gcc] Error 2
    make[1]: Leaving directory `/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4-initial’
    make: *** [/home/user/Minimorph_1_0/GPL/buildroot/output/toolchain/gcc-4.2.4-initial/.compiled] Error 2

    #64787

    Sean
    Moderator

    What arguments did you give make? You need to specify the arch. Have you setup the environment variable CROSS_COMPILE?

    Sean.

    #64786

    surender
    Member

    hi
    this error occured while make in buildroot for arch=meta (given in menuconfig), i assume CROSS_COMPILE is not required at this step

    #64785

    Sean
    Moderator

    Having built buildroot, you will have to export CROSS_COMPILE as follows before entering the metag-linux directory:
    export CROSS_COMPILE=`pwd`/buildroot/output/host/usr/bin/metag-linux-
    The arch is ‘metag
    $ make ARCH=metag

    #64784

    Sean
    Moderator

    The reason I suggest this is that it looks like you are using your standard gcc, not the Meta aware one. This is shown by the error:
    Error: unrecognized option -minim

    #64783

    surender
    Member

    now im stuck at

    arch/metag/kernel/cachepart.c: In function ‘get_thread_cache_size’:
    arch/metag/kernel/cachepart.c:65: error: implicit declaration of function ‘get_global_dache_size’
    make[1]: *** [arch/metag/kernel/cachepart.o] Error 1
    make: *** [arch/metag/kernel] Error 2

    #64782

    Sean
    Moderator

    I’m not sure on that one – I’ll have to take a closer look tomorrow.

    Just to check, did you run the following before running make?
    $ make ARCH=metag comet_minimorph_defconfig

    #64781

    surender
    Member

    hi Sean
    i’ve done the following steps

    in buildroot
    exported CROSS_COMPILE
    $make ARCH=metag comet_minimorph_defconfig
    $make ARCH=metag
    $ cp buildroot/output/images/rootfs.cpio metag-linux-2.6/arch/metag/boot/ramdisk.cpio

    For building kernel
    $make ARCH=metag menuconfig
    $ make ARCH=metag CROSS_COMPILE=`my current path`/buildroot/output/host/usr/bin/metag-linux-

    still im finding the same issue…

    CC arch/metag/kernel/cachepart.o
    arch/metag/kernel/cachepart.c: In function ‘get_thread_cache_size’:
    arch/metag/kernel/cachepart.c:65: error: implicit declaration of function ‘get_global_dache_size’
    make[1]: *** [arch/metag/kernel/cachepart.o] Error 1
    make: *** [arch/metag/kernel] Error 2

    i’ve seen a patch for meta 3.3, seems to be updated here in 3.6…still no clue

    #64780

    Sean
    Moderator

    You appear to be building from using older documentation for the Minimorph SDK.

    The following line is not in the latest documentation set and there are a number of other changes.
    $ cp buildroot/output/images/rootfs.cpio metag-linux-2.6/arch/metag/boot/ramdisk.cpio

    If you look on https://www.imgtec.com/meta_insider/metaflow-sdk.asp you will find the latest versions of all of the files.

    Please ensure you follow the instructions exactly as they are documented on pages 18, 19 and 20 of Meta Flow SDK.Reference Manual.1-9.pdf

    Please confirm you have downloaded and are building from the following file:
    Minimorph_1_0-rel009.tar.gz

    Please note that this cannot be unpacked over an existing build … it needs to be unpacked to a new location and built from scratch.

    Regards,

    Sean.

    #64779

    surender
    Member

    hi sean,
    now i can build vmlinux, but it’s size is almost 50MB, suggest me to reduce its size
    comet board unable to load vmlinux more than 8MB

    thanks
    surender

    #64778

    Sean
    Moderator

    Have you included extra buildroot packages?

    #64777

    surender
    Member

    Hi Seanr

    i’ve disabled debug symbols, it worked for me
    thanks i’m able to work on it….

    #64776

    Sean
    Moderator

    Great – let me know if you have any further issues.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.