something went wrong, when I downloaded program to the MIPSfpga core

Home Forums MIPS Insider MIPSfpga something went wrong, when I downloaded program to the MIPSfpga core

This topic contains 3 replies, has 3 voices, and was last updated by  Robert Owen 1 year, 10 months ago.

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #64480

    Ke
    Participant

    I wrote a small prog and “make” then used the blaster load to MIPSfpga. When it finished, it showed
    Error: fast_data (0x80000000) is within write area (0x80000000-0x80000086).
    Error: Change work-area-phys or load_image address!
    I don’t know what’s wrong with it and how to get it fixed. If you just got any idea please tell me as soon as possible.Thanks.

    #64483

    Robert Owen
    Participant

    Useful reply from Prof. Chaver-Martinez at UCM:
    “I think that error should not cause OpenOCD/gdb not to work. We suggest to try an example program among those provided with the package (for example “AssemblyExample”). You will probably will obtain the same error but you should be able to debug the program with gdb/OpenOCD.
    In that case, probably there is a problem in the program he wrote.”

    #64482

    Ke
    Participant

    Yes, that’s right. I’ve tried several times before asking the question and the error does occur. I thought that there was sth wrong with my project, but now I don’t have to worry about that. Thanks a lot.
    Well, anyway, I feels somewhat uncomfortable with the little bug…

    #64481

    Hazel
    Participant

    Hi..i am a new user here. As per my knowledge its true as said above that the error should not cause OpenOCD/gdb not to work. We suggest to try an example program among those provided with the package . You will probably will obtain the same error but you should be able to debug the program with gdb/OpenOCD

Viewing 4 posts - 1 through 4 (of 4 total)

Forums are currently locked.