SSH connection

Home Forums Creator Platforms SSH connection

This topic contains 7 replies, has 3 voices, and was last updated by  Matt Atkinson 4 years, 8 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #63751

    Brian Beuken

    I’m having a little trouble with my new ci20 its all working fine, but I can’t seem to make an SSH connection to it from my PC, using ci20/ci20 as a username/password combo
    It actively refuses the connection, suggesting one or both is wrong.

    I can’t seem to locate any info on SSH connections here, can someone advise me on the correct connection inputs?




    Matt Atkinson

    Hi Brian,

    I’ve just tried:

    ssh ci20@<IP ADDRESS>

    and then entered the password ‘ci20’ when prompted and it worked ok. This is using Debian 7 on Ci20 and an Ubuntu 14.04 laptop.

    Is this exactly what you have tried?

    The elinux page has some more instructions on remotely accessing your board which may be helpful.

    Let us know if that helps. If not, any more information you can provide would be useful to help understand how your setup might be different to mine.






    It might be that password authentication isn’t enabled.

    On your ci20, edit the file

    sudo nano /etc/ssh/sshd_config

    Search for PasswordAuthentication

    It should look like this with no # in front to comment it out.

    PasswordAuthentication yes



    Brian Beuken

    HI Matt

    no I’m using Debian 7 on the Ci20 as supplied on eMMC and updated, but on PC, VisualGDB and Visual Studio SSH manager on windows…

    ZubairLK, that sounds like a good idea, I’ll check later tonight and let you know


    Brian Beuken

    hmm I don’t appear to have an SSH directory in etc


    Matt Atkinson

    It says in here that the factory default debian image does not have ssh, so you would need to install it with apt-get. If you have already installed it and it doesn’t work, are you able to tell us the exact error you see? Does your SSH client make a connection and fail to authenticate, or does it fail to make a connection in the first place?


    Brian Beuken

    ah that indeed makes more sense, thanks Matt, again I will try this tonight.


    Brian Beuken

    Thanks Matt, that was indeed the problem, I had assumed SSH was installed and it wasn’t, now I’ve done a
    apt-get install ssh

    all is fine.. appreciate the help

Viewing 8 posts - 1 through 8 (of 8 total)

Forums are currently locked.