Unable to connect MInimorph to the host

Home Forums MIPS Insider Meta Insider Unable to connect MInimorph to the host

This topic contains 21 replies, has 2 voices, and was last updated by  Sean 4 years, 9 months ago.

Viewing 15 posts - 1 through 15 (of 22 total)
  • Author
  • #64683


    Hey, there, here is a very strange thing happened. When I connect my board to the host, the LED 2 keeps light and the LED 2 flashes about every 9 seconds. The board cann’t make the connection with my host PC in this situation. However, if I tried to unplug my board and plug it for some times, the board turns normal and set the connection. May I know the reason of this situation? What does the board mean when the LEDs perform like that?



    It’s not clear the cause of this behaviour.

    How are you powering your board? Through the USB cable?
    Do you have a micro SD card in the slot?

    When you say LED2 flashes, is it just one quick flash? Is it consistently about every 9 seconds?

    Do you have a HDMI monitor/TV you can connect to view the display?




    I power my board through a USB cable and I have a SD card in the slot. The LED1 lights consistently for about 2 seconds in about every 10 seconds while the LED2 keeps lighting. I am sorry, there is no HDMI monitor to view the display.



    In addition, there is no file for boot in my SD card, only some .txt files inside.



    What LDR file have you flashed onto the Minimorph?

    Are any of the buttons being pressed as you connect the USB cable to the board?

    Is the board sitting on a non-conductive surface?




    Starting kernel …

    Linux version 3.6.0 (gshore@lemeta02.le.imgtec.org) (gcc version 4.2.4 (IMG- #2 Thu Feb 7 16:03:18 GMT 2013
    DA not present
    Machine: 01TT Comet MiniMorph, model: ImgTec Comet MiniMorph
    Fixing priv protection on T0 local MMU table region
    Fixing priv protection on T0 global MMU table region
    Fixing priv protection on T1 global MMU table region
    Node 0: start_pfn = 0xb0000, low = 0xbfa00
    Zone ranges:
    Normal [mem 0xb0000000-0xbf9fffff]
    Movable zone start for each node
    Early memory node ranges
    node 0: [mem 0xb0000000-0xbf9fffff]
    Built 1 zonelists in Zone order, mobility grouping on. Total pages: 63500
    Kernel command line: console=ttyS0,115200 mtdparts=spi0.0-AT45DB642x:0x840000@0x0(raw),0x1ff80@0x1080(NVS1),0x3c960@0x21000(LDLK),0x19860@0x5d960(BOOT),0x618480@0x771c0(LKGZ) pdpfb.videomem_base=0xbfa00000 pdpfb.videomem_len=0x400000
    PID hash table entries: 1024 (order: 0, 4096 bytes)
    Dentry cache hash table entries: 32768 (order: 5, 131072 bytes)
    Inode-cache hash table entries: 16384 (order: 4, 65536 bytes)
    Memory: 245220k/256000k available
    Normal per-cpu:
    CPU 0: hi: 0, btch: 1 usd: 0
    active_anon:0 inactive_anon:0 isolated_anon:0
    active_file:0 inactive_file:0 isolated_file:0
    unevictable:0 dirty:0 writeback:0 unstable:0
    free:61305 slab_reclaimable:0 slab_unreclaimable:0
    mapped:0 shmem:0 pagetables:0 bounce:0
    Normal free:245220kB min:0kB low:0kB high:0kB active_anon:0kB inactive_anon:0kB active_file:0kB inactive_file:0kB unevictable:0kB isolated(anon):0kB isolated(file):0kB present:254000kB mlocked:0kB dirty:0kB writeback:0kB mapped:0kB shmem:0kB slab_reclaimable:0kB slab_unreclaimable:0kB kernel_stack:0kB pagetables:0kB unstable:0kB bounce:0kB writeback_tmp:0kB pages_scanned:0 all_unreclaimable? no
    lowmem_reserve[]: 0 0
    Normal: 1*4kB 0*8kB 0*16kB 1*32kB 1*64kB 1*128kB 1*256kB 0*512kB 1*1024kB 1*2048kB 59*4096kB = 245220kB
    0 total pagecache pages
    64000 pages RAM
    2695 pages reserved
    0 pages shared
    0 pages non-shared
    meta-intc: External IRQ controller initialised (64 IRQs)
    Setting up IRQs for GPIO block 0
    Setting up IRQs for GPIO block 1
    Setting up IRQs for GPIO block 2
    Console: colour dummy device 80×25
    Calibrating delay loop… 589.00 BogoMIPS (lpj=2945024)
    pid_max: default: 32768 minimum: 301
    Mount-cache hash table entries: 512
    devtmpfs: initialized
    Added Core Code Memory TCM pool (00010000 bytes @ 80000000)
    Added Core Data Memory TCM pool (00010000 bytes @ 82000000)
    Added Internal Memory TCM pool (00060000 bytes @ e0200000)
    NET: Registered protocol family 16
    Comet Soc: XTAL1 is 24576000 HZ
    Comet Soc: XTAL2 is 12000000 HZ
    Comet Soc: XTAL3 is 32768 HZ
    Comet Soc: Clocks:
    Comet Soc: x09Core Clock 480768000 HZ
    Comet Soc: x09Sys Clock (Pre deleter) 240384000 HZ
    Comet Soc: x09DDR Clock 480768000 HZ
    Comet Uart Init: Requested 1843200 HZ Uart Clock, Actual Uart CLk = 1890461 HZ
    pdc-intc 2006000.pdc: PDC IRQ controller initialised (3 perip IRQs, 3 syswake IRQs)
    Comet SD-Host Init: Requested 100000000 HZ SD Clock Actual SF CLk = 80128000 HZ
    bio: create slab at 0
    usbcore: registered new interface driver usbfs
    usbcore: registered new interface driver hub
    usbcore: registered new device driver usb
    Advanced Linux Sound Architecture Driver Version 1.0.25.
    cfg80211: Calling CRDA to update world regulatory domain
    Switching to clocksource META
    NET: Registered protocol family 2
    TCP established hash table entries: 8192 (order: 4, 65536 bytes)
    TCP bind hash table entries: 8192 (order: 3, 32768 bytes)
    TCP: Hash tables configured (established 8192 bind 8192)
    TCP: reno registered
    UDP hash table entries: 256 (order: 0, 4096 bytes)
    UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
    NET: Registered protocol family 1
    msgmni has been set to 478
    io scheduler noop registered (default)
    imgpdi-lcd imgpdi-lcd: IMG PDI (id: 0c:01:0008, revision: 1.1.0) probed successfully
    pdpfb pdpfb: videomem @0xbfa00000:0x400000 (ioremapped to 0x78000000)
    Console: switching to colour frame buffer device 100×37
    pdpfb pdpfb: registered graphics framebuffer (len=0x300000)
    pdpfb pdpfb: registered video framebuffer (len=0x100000)
    pdpfb pdpfb: PDP id: 0x7010001 revision: 1.0.1
    Serial: 8250/16550 driver, 2 ports, IRQ sharing disabled
    2004b00.uart: ttyS0 at MMIO 0x2004b00 (irq = 68) is a 8250
    console [ttyS0] enabled
    2004c00.uart: ttyS1 at MMIO 0x2004c00 (irq = 69) is a 8250
    timeriomem_rng timeriomem_rng: 32bits from 0x02004288 @ 0us
    uccp uccp: uccp0 detected with config: 0x0000, rev: 2.0.1
    uccp uccp: uccp1 detected with config: 0x0000, rev: 2.0.1
    sgx2d sgx2d: SGX 2D module loaded
    brd: module loaded
    img-spi img-spi.1: SPI clock requested: 40000000 HZ. Actual SPI clock: 34340571 (status=0)
    img-spi img-spi.1: master is unqueued, this is deprecated
    img_mdc_dma: Using address not aligned to system bus width, this will impact performance
    mtd_dataflash spi1.0: AT45DB642x (8448 KBytes) pagesize 1056 bytes, OTP
    pegasus: v0.6.14 (2006/09/27), Pegasus/Pegasus II USB Ethernet driver
    usbcore: registered new interface driver pegasus
    usbcore: registered new interface driver asix
    dwc_otg: version 2.90a 23-APR-2009 with Bug Fixes from IMG
    dwc_otg: Core Release: 2.90b
    dwc_otg: Using Descriptor DMA mode
    dwc_otg: Periodic Transfer Interrupt Enhancement – disabled
    dwc_otg: Multiprocessor Interrupt Enhancement – disabled
    dwc_otg: Dedicated Tx FIFOs mode
    dwc_otg: Using DMA mode
    dwc_otg dwc_otg.0: DWC OTG Controller
    dwc_otg dwc_otg.0: new USB bus registered, assigned bus number 1
    dwc_otg dwc_otg.0: irq 83, io mem 0x00000000
    dwc_otg: Init: Port Power? op_state=4
    hub 1-0:1.0: USB hub found
    hub 1-0:1.0: 1 port detected
    mousedev: PS/2 mouse device common for all mice
    pdc-rtc 2006100.rtc: rtc core: registered 2006100.rtc as rtc0
    i2c /dev entries driver
    img-i2c img-i2c.2: IMG I2C adapter ( probed successfully (standard 101781 bps)
    sii9022a-tpi 2-0039: SiI9022a/9024a HDMI Transmitter.
    dwc_otg: USB RESET
    sii9022a-tpi 2-0039: SiI922x HDMI Transmitter probed successfully.
    Registered IR keymap rc-empty
    input: IMG Infrared Decoder as /devices/virtual/rc/rc0/input0
    rc0: IMG Infrared Decoder as /devices/virtual/rc/rc0
    img-ir 2006200.ir: IMG IR Decoder ( probed successfully
    imgpdc-wdt 2006000.wdt: Watchdog module loaded (last reset due to hard reset)
    Synopsys Designware Multimedia Card Interface Driver
    dw_mmc dw_mmc.0: Version ID is 210a
    dw_mmc dw_mmc.0: DW MMC controller at irq 84, 32 bit host data width, 32 deep fifo
    usbcore: registered new interface driver usbhid
    usbhid: USB HID core driver
    mmcIn: serial
    Out: vga
    Err: vga

    U-Boot 2012.07 (Feb 07 2013 – 16:02:29)

    MMC: dw_mmc 2.10a Slot 0: 0

    Boot mode: SD Boot
    reading u-boot.scr

    ** Unable to read “u-boot.scr” from mmc 0:1 **
    reading vmlinux.ub

    ** Unable to read “vmlinux.ub” from mmc 0:1 **
    SD Boot failed, booting from flash…
    Reclaimed 4194304 bytes of HEAP space at base address 0x4fa00000
    Loading 6390912 byte LKGZ from 0xf00772c0 to 0x41000000
    ## Booting kernel from Legacy Image at 41000000 …
    Image Name: Meta Linux
    Image Type: METAG Linux Kernel Image (gzip compressed)
    Data Size: 6390319 Bytes = 6.1 MiB
    Load Address: 40000000
    Entry Point: 40000000
    Verifying Checksum … OK
    Uncompressing Kernel Image … OK

    Starting kernel …



    I connected the serial port to get the output from there, and this is what it says



    I boot the default files to the board and no button is pressed.



    Great, and is this when it initalises correctly?

    If you could check the console out (from the serial) when it does not come up correctly and let me know what it says, if anything, that would be helpful.




    Ok, and are you sure that there is nothing under or on the minimorph that could be shorting any of the pins/connectors/components/contacts?




    Firstly, the log I send you is under the incorrect situation. I tried to run a program via the board (at that time , the connection is established), and the connection dropped . Then, the LEDs shows what I described earlier. At the mean time, the serial port output the log I send to you. As I cann’t establish the connection now, I cann’t check the files on the board ,so I can not answer the second question.



    This situation happens only when I insert a SD card.



    I just searched the root file of the minimorph on my host PC (/GPL/biuldroot/output/target). There is no such files. As I never U-Boot the board, I believe the root files should be the same as the filesystem on my board. Thus, I think there is no such file on my board.



    From your transcript, it looks like your board has been resetting. This is commonly because the USB port is not bale to supply enough current.

    As I and my colleague have suggested, I think that some of your issues can be resolved by using an external 5v PSU (Power Supply Unit) rather than powering the Minimorph using USB.

    I will email you directly about sourcing this.




    Please note that when I ask “are you sure that there is nothing under or on the minimorph that could be shorting any of the pins/connectors/components/contacts?

    I am asking you if there is physically any metal touching the board on the top or the bottom – I am not asking you to look for a file. When I use a slash in this context, I mean ‘or’; so read it “… could be shorting any of the pins or connectors or components or contacts“.

    If it is on a metal surface or there are stray wires, they can join terminals or pins together causing issues in the board operation.

Viewing 15 posts - 1 through 15 (of 22 total)

Forums are currently locked.